Wednesday, January 21, 2009

Rails Error: Rails requires RubyGems >= 1.3.1 (you have 1.2.0).

I tried setting up a new rails project today. After I updated to the new rails version 2.2.2, I got the following error when attempting to run my WEBrick server.

"Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update --system` and try again.

So I did what It said.

gem update --system
and it returned 'Nothing to Update'

I solved this problem by running
gem install rubygems-update
and then...

that actually did the updating.
After the gem updates I was back in business.

No comments:

Post a Comment